Hello, guest. We have noticed that you are not registered at this bug tracker. Your experience will be greatly enhanced if you log in. To do so, you first must register by clicking on the Register tab at the top. If you are already registered, you can login at the Login tab.
Syndicate Syndicate Listing Display Search Login/Register
Bug Id ?
Reporter ?
Rob
Product/Version ?
HardInfo / Current development version
Status ?
Unconfirmed
Severity ?
Major
Duplicate Of ?
- none -
Summary ?
In "Release" or "RelWithDebInfo" modes, not all cpu test results are reported
Report Time ?
November 15, 2011 01:46:21 PM
Assignment ?
- none -
Resolution ?
Open
Priority ?
Normal
Dependencies ?
- none -


Votes
For: 0 (0%)
Against: 0 (0%)
Total: 0

November 15, 2011 01:46:21 PM Rob
If the CMAKE_BUILD_TYPE is set to RelWithDebInfo or Release, the cpu statistics 'This Machine' are not reported.

Running the debug version outputs the results.

Removing optimisation from the release version (-O3, -O2, etc.) does not correct this.

The only the CPU Fibonacci test reports results.

Running latest development version (f28dbb3158054925808f4bdadd608794a44eb692) on Debian Squeeze, Atom processor

$ hardinfo --version:
HardInfo version 0.5.2pre
Copyright (C) 2003-2009 Leandro A. F. Pereira. See COPYING for details.

Compile-time options:
Release version: Yes (ARCH_x86)
BinReloc enabled: Yes
Data prefix: /usr/local/share/hardinfo
Library prefix: /usr/local/lib/hardinfo
Compiled on: linux-ARCH_x86 2.6.32-5-686 ()
Modules:
File Name Name Version
libcomputer.so Computer 0.5.2pre
libdevices.so Devices 0.5.2pre
libnetwork.so Network 0.5.2pre
libbenchmark.so Benchmarks 0.5.2pre