Hello, guest. We have noticed that you are not registered at this bug tracker. Your experience will be greatly enhanced if you log in. To do so, you first must register by clicking on the Register tab at the top. If you are already registered, you can login at the Login tab.
Syndicate Syndicate Listing Display Search Login/Register
Bug Id ?
Reporter ?
Guest
Product/Version ?
HardInfo / Older than 0.5
Status ?
Closed
Severity ?
Trivial
Duplicate Of ?
- none -
Summary ?
Incorrect processor information for AMD 64
Report Time ?
October 5, 2009 08:36:28 PM
Assignment ?
- none -
Resolution ?
Works for Me
Priority ?
Low
Dependencies ?
- none -


Attachments
Screenshot-Processor - System Information-1.png Screenshot
cpuinfo proc/cpuinfo
Votes
For: 0 (0%)
Against: 0 (0%)
Total: 0

October 5, 2009 08:36:28 PM Guest
I have an AMD 64 bit dual core CPU. HardInfo is reporting that it suffers from the "FDIV bug", which presumably refers to a bug which only applies to Intel Pentium processors. It is impossible that my CPU suffers this bug because it isn't a pentium.

October 5, 2009 08:43:05 PM KevinN
(I was the original reporter)

October 5, 2009 11:09:21 PM Leandro Pereira
AFAIK, this has been fixed in 0.5. Could you please attach your /proc/cpuinfo file?

October 5, 2009 11:30:04 PM KevinN
Here it is. Note that additional information (other files/attachments, the state of the program w.r.t. proc, etc) is available at https://bugs.launchpad.net/ubuntu/+source/hardinfo/+bug/444009 .

October 6, 2009 01:18:03 AM Leandro Pereira
Indeed, it does not show this behavior with 0.5. Updating to 0.5.1 is recommended, but if you need a patch for 0.4.2.3, let me know.